AspectJ 1.9.0 and Java 9

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

AspectJ 1.9.0 and Java 9

Adam Rauch
Is there a plan to produce an updated build of 1.9.0? We've attempted to
test our code with 1.9.0 beta 3, but this JAR appears to be more than a
year old and not compatible with recent Java 9 builds. When we compile
under JDK 9, AspectJ can't seem to find standard classes String,
HashMap, etc., which may be related to this post
http://dev.eclipse.org/mhonarc/lists/aspectj-users/msg14994.html

Thanks,
Adam
_______________________________________________
aspectj-users mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/aspectj-users
Reply | Threaded
Open this post in threaded view
|

Re: AspectJ 1.9.0 and Java 9

Andy Clement
Hey,

> Is there a plan to produce an updated build of 1.9.0?

Yep.  Actually beta-5 is the latest and I believe is what Spring Framework is using to build aspect libraries.

Now beta-5 is a little bit old now, and I haven’t personally tested it against recent java9 builds, so do let me know if there are problems and I’ll see what I can do. I wouldn’t expect beta3 to work.  As Java9 gets closer and eclipse jdt java 9 support settles down, there will be another big update.

cheers,
Andy

> On Feb 19, 2017, at 12:18 PM, Adam Rauch <[hidden email]> wrote:
>
> Is there a plan to produce an updated build of 1.9.0? We've attempted to test our code with 1.9.0 beta 3, but this JAR appears to be more than a year old and not compatible with recent Java 9 builds. When we compile under JDK 9, AspectJ can't seem to find standard classes String, HashMap, etc., which may be related to this post http://dev.eclipse.org/mhonarc/lists/aspectj-users/msg14994.html
>
> Thanks,
> Adam
> _______________________________________________
> aspectj-users mailing list
> [hidden email]
> To change your delivery options, retrieve your password, or unsubscribe from this list, visit
> https://dev.eclipse.org/mailman/listinfo/aspectj-users

_______________________________________________
aspectj-users mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/aspectj-users
Reply | Threaded
Open this post in threaded view
|

Re: AspectJ 1.9.0 and Java 9

Adam Rauch
Thanks and great to hear, Andy. So, where might I find beta 5? The
download page (http://www.eclipse.org/aspectj/downloads.php) provides
1.9.0 beta 3 as the "latest" Java 9 compatible version. I haven't found
1.9.0 on Maven Central.

Thanks,
Adam

On 2/20/2017 5:26 PM, Andy Clement wrote:

> Hey,
>
>> Is there a plan to produce an updated build of 1.9.0?
> Yep.  Actually beta-5 is the latest and I believe is what Spring Framework is using to build aspect libraries.
>
> Now beta-5 is a little bit old now, and I haven’t personally tested it against recent java9 builds, so do let me know if there are problems and I’ll see what I can do. I wouldn’t expect beta3 to work.  As Java9 gets closer and eclipse jdt java 9 support settles down, there will be another big update.
>
> cheers,
> Andy
>
>> On Feb 19, 2017, at 12:18 PM, Adam Rauch <[hidden email]> wrote:
>>
>> Is there a plan to produce an updated build of 1.9.0? We've attempted to test our code with 1.9.0 beta 3, but this JAR appears to be more than a year old and not compatible with recent Java 9 builds. When we compile under JDK 9, AspectJ can't seem to find standard classes String, HashMap, etc., which may be related to this post http://dev.eclipse.org/mhonarc/lists/aspectj-users/msg14994.html
>>
>> Thanks,
>> Adam
>> _______________________________________________
>> aspectj-users mailing list
>> [hidden email]
>> To change your delivery options, retrieve your password, or unsubscribe from this list, visit
>> https://dev.eclipse.org/mailman/listinfo/aspectj-users
> _______________________________________________
> aspectj-users mailing list
> [hidden email]
> To change your delivery options, retrieve your password, or unsubscribe from this list, visit
> https://dev.eclipse.org/mailman/listinfo/aspectj-users

_______________________________________________
aspectj-users mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/aspectj-users
Reply | Threaded
Open this post in threaded view
|

Re: AspectJ 1.9.0 and Java 9

Andy Clement
Hey,

Releases go to central, betas are only hosted here alongside other AspectJ milestones:

<repository>
    <id>repo.spring.io</id>
    <name>SpringSource milestones</name>
    <url>http://repo.spring.io/milestone</url>
</repository>
1.9.0.BETA-5
​It should be on the download page but looks like I was in too much of a rush. I'll try to fix that.​

​cheers,​
​Andy​


On 20 February 2017 at 18:02, Adam Rauch <[hidden email]> wrote:
Thanks and great to hear, Andy. So, where might I find beta 5? The download page (http://www.eclipse.org/aspectj/downloads.php) provides 1.9.0 beta 3 as the "latest" Java 9 compatible version. I haven't found 1.9.0 on Maven Central.

Thanks,
Adam


On 2/20/2017 5:26 PM, Andy Clement wrote:
Hey,

Is there a plan to produce an updated build of 1.9.0?
Yep.  Actually beta-5 is the latest and I believe is what Spring Framework is using to build aspect libraries.

Now beta-5 is a little bit old now, and I haven’t personally tested it against recent java9 builds, so do let me know if there are problems and I’ll see what I can do. I wouldn’t expect beta3 to work.  As Java9 gets closer and eclipse jdt java 9 support settles down, there will be another big update.

cheers,
Andy

On Feb 19, 2017, at 12:18 PM, Adam Rauch <[hidden email]> wrote:

Is there a plan to produce an updated build of 1.9.0? We've attempted to test our code with 1.9.0 beta 3, but this JAR appears to be more than a year old and not compatible with recent Java 9 builds. When we compile under JDK 9, AspectJ can't seem to find standard classes String, HashMap, etc., which may be related to this post http://dev.eclipse.org/mhonarc/lists/aspectj-users/msg14994.html

Thanks,
Adam
_______________________________________________
aspectj-users mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/aspectj-users
_______________________________________________
aspectj-users mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/aspectj-users

_______________________________________________
aspectj-users mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/aspectj-users


_______________________________________________
aspectj-users mailing list
[hidden email]
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/aspectj-users